Discussion:
Problem with Horde "Mailbox does not support mod-sequences"
(too old to reply)
Luca Bertoncello
2017-02-13 13:14:45 UTC
Permalink
Hi list!

I have a Server with Debian 8 and Dovecot 2.2.13-12 (from Debian
repositories) and Horde 5.2.13.

When I delete an E-Mail, I always get the error "Mailbox does not
support mod-sequences".
It results in having the E-Mail not moved to Trash and I must update
more times the folder to see the E-Mail moved to Trash...

Unfortunately, I couldn't get any help from Dovecot list, so I'm
trying here, with the hope that someone here use Dovecot, too...

Could someone help me to add this support for mod-sequences?

Thanks a lot!
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Hendrik Noack
2017-02-13 13:47:29 UTC
Permalink
-----Ursprüngliche Nachricht-----
Bertoncello
Gesendet: Montag, 13. Februar 2017 14:15
Betreff: [horde] Problem with Horde "Mailbox does not support mod-
sequences"
Hi list!
I have a Server with Debian 8 and Dovecot 2.2.13-12 (from Debian
repositories) and Horde 5.2.13.
When I delete an E-Mail, I always get the error "Mailbox does not support
mod-sequences".
It results in having the E-Mail not moved to Trash and I must update more
times the folder to see the E-Mail moved to Trash...
Unfortunately, I couldn't get any help from Dovecot list, so I'm trying
here,
with the hope that someone here use Dovecot, too...
Could someone help me to add this support for mod-sequences?
Thanks a lot!
Luca Bertoncello
--
Horde mailing list
Hi Luca,

I do use Debian 8 with Dovecot and Horde 5.2.17. I never experienced this
error before, but I don't think it is related to Horde. Is it a general
problem or does it only happen to some users?

You could rule out horde by using an IMAP client like thunderbird against
your dovecot server. Horde is just using IMAP (via php). Are you using the
default imp IMAP configuration or did you customized it? If so, could you
please try it with the default (if thats possible in your setup)?

If you can rule out horde it must be some kind of problem with the dovecot
configuration or with specific mailboxes. If you use maildir format, you
could try to make a backup of the mailbox directory and start fresh to see
if that helps. You can even copy a few mail files back in there, dovecot
should rebuild the index by itself the next time you access the directory
from an IMAP client. Try to delete them.

If nothing helps, you might have to enabled debug log in dovecot and
reproduce the error. Maybe there is something in logs that points you in the
right direction. Needles to say that file system permission should be
checked first, right? ;-)

Mit freundlichen Grüßen / Best regards

Hendrik Noack


--
Axxedia IT GmbH

Schwabstr. 30
71106 Magstadt

Tel +49 7159 4979763
Fax +49 7159 4979775

Mail ***@axxedia-it.de

Sitz der Gesellschaft: Schwabstr. 30, 71106 Magstadt
Geschäftsführer: Hendrik Noack . Amtsgericht: Stuttgart HRB 727296
Luca Bertoncello
2017-02-13 14:04:31 UTC
Permalink
Zitat von Hendrik Noack <***@axxedia-it.de>:

Hi Hendrik,
Post by Hendrik Noack
I do use Debian 8 with Dovecot and Horde 5.2.17. I never experienced this
error before, but I don't think it is related to Horde. Is it a general
problem or does it only happen to some users?
No, the problem is for all users...
Post by Hendrik Noack
You could rule out horde by using an IMAP client like thunderbird against
how can I do that?
Post by Hendrik Noack
your dovecot server. Horde is just using IMAP (via php). Are you using the
default imp IMAP configuration or did you customized it? If so, could you
please try it with the default (if thats possible in your setup)?
I just gived the Server, the Port and said, that TLS should be used...
Then I checked "cache IMAP-Folder".
Is that what you mean?
Post by Hendrik Noack
If you can rule out horde it must be some kind of problem with the dovecot
configuration or with specific mailboxes. If you use maildir format, you
could try to make a backup of the mailbox directory and start fresh to see
if that helps. You can even copy a few mail files back in there, dovecot
should rebuild the index by itself the next time you access the directory
from an IMAP client. Try to delete them.
I have a test account and I tried with it. Same problem...
Post by Hendrik Noack
If nothing helps, you might have to enabled debug log in dovecot and
reproduce the error. Maybe there is something in logs that points you in the
right direction. Needles to say that file system permission should be
checked first, right? ;-)
Maybe could we compare our configuration files? You can send me a PN...

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Maurício Jsé T. Tecles
2017-02-13 14:07:56 UTC
Permalink
Post by Hendrik Noack
-----Ursprüngliche Nachricht-----
Bertoncello
Gesendet: Montag, 13. Februar 2017 14:15
Betreff: [horde] Problem with Horde "Mailbox does not support mod-
sequences"
Hi list!
I have a Server with Debian 8 and Dovecot 2.2.13-12 (from Debian
repositories) and Horde 5.2.13.
When I delete an E-Mail, I always get the error "Mailbox does not support
mod-sequences".
It results in having the E-Mail not moved to Trash and I must update more
times the folder to see the E-Mail moved to Trash...
Unfortunately, I couldn't get any help from Dovecot list, so I'm trying
here,
with the hope that someone here use Dovecot, too...
Could someone help me to add this support for mod-sequences?
Thanks a lot!
Luca Bertoncello
--
Horde mailing list
Hi Luca,
I do use Debian 8 with Dovecot and Horde 5.2.17. I never experienced this
error before, but I don't think it is related to Horde. Is it a general
problem or does it only happen to some users?
You could rule out horde by using an IMAP client like thunderbird against
your dovecot server. Horde is just using IMAP (via php). Are you using the
default imp IMAP configuration or did you customized it? If so, could you
please try it with the default (if thats possible in your setup)?
If you can rule out horde it must be some kind of problem with the dovecot
configuration or with specific mailboxes. If you use maildir format, you
could try to make a backup of the mailbox directory and start fresh to see
if that helps. You can even copy a few mail files back in there, dovecot
should rebuild the index by itself the next time you access the directory
from an IMAP client. Try to delete them.
If nothing helps, you might have to enabled debug log in dovecot and
reproduce the error. Maybe there is something in logs that points you in the
right direction. Needles to say that file system permission should be
checked first, right? ;-)
I use Debian 8, Dovecot and Postfix from Debian distribution, no
problems here.

Have you checked your mail logs? Take a look at:

http://wiki2.dovecot.org/Errors/ChgrpNoPerm

Mauricio
Post by Hendrik Noack
Mit freundlichen Grüßen / Best regards
Hendrik Noack
--
Axxedia IT GmbH
Schwabstr. 30
71106 Magstadt
Tel +49 7159 4979763
Fax +49 7159 4979775
Sitz der Gesellschaft: Schwabstr. 30, 71106 Magstadt
Geschäftsführer: Hendrik Noack . Amtsgericht: Stuttgart HRB 727296
--
Maurício José T. Tecles
Instituto de Biofísica Carlos Chagas Filho/UFRJ
Av. Carlos Chagas Filho, 373
Núcleo de Informática
CCS, Bloco G, sala G1-006
Cidade Universitária - Ilha do Fundão
21941-902, Rio de Janeiro - RJ

***@biof.ufrj.br
Tel.: (21) 3938-6526 ou 3938-6544
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-
Luca Bertoncello
2017-02-13 14:12:27 UTC
Permalink
Zitat von "Maurício Jsé T. Tecles" <***@biof.ufrj.br>:

Hi Maurício
Post by Maurício Jsé T. Tecles
I use Debian 8, Dovecot and Postfix from Debian distribution, no
problems here.
Am I alone with Dovecot and problems? :)
I had the same problem with my old Server (Ubuntu Server 10.04 and
Dovecot 1)...
Post by Maurício Jsé T. Tecles
http://wiki2.dovecot.org/Errors/ChgrpNoPerm
I don't have these errors in the logs...

Regards
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, ma
Luca Bertoncello
2017-02-13 14:14:33 UTC
Permalink
Post by Hendrik Noack
I do use Debian 8 with Dovecot and Horde 5.2.17. I never experienced this
error before, but I don't think it is related to Horde. Is it a general
problem or does it only happen to some users?
You could rule out horde by using an IMAP client like thunderbird against
your dovecot server. Horde is just using IMAP (via php). Are you using the
default imp IMAP configuration or did you customized it? If so, could you
please try it with the default (if thats possible in your setup)?
If you can rule out horde it must be some kind of problem with the dovecot
configuration or with specific mailboxes. If you use maildir format, you
could try to make a backup of the mailbox directory and start fresh to see
if that helps. You can even copy a few mail files back in there, dovecot
should rebuild the index by itself the next time you access the directory
from an IMAP client. Try to delete them.
Another information:

I just have this problem if I do something in the INBOX folder!
On other folder (sent, spam, and so on) the problem does not happen...

Very very strange...

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Luca Bertoncello
2017-02-13 14:30:53 UTC
Permalink
Post by Luca Bertoncello
I just have this problem if I do something in the INBOX folder!
On other folder (sent, spam, and so on) the problem does not happen...
Enable IMAP debug logging in IMP. See imp/config/backends.php
I tried it, but it does not log...
What have I to add?
I tried to add:

'debug' => '/tmp/imp_imap.log'

in the section "$servers['imap']", but it does not work...

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Luca Bertoncello
2017-02-13 15:10:33 UTC
Permalink
Post by Luca Bertoncello
What have I to add?
'debug' => '/tmp/imp_imap.log'
in the section "$servers['imap']", but it does not work...
Are you sure the 'imap' configuration is the active one? Do you have
a backends.local.php file?
No, I haven't...

This is the section:

$servers['imap'] = array(
// ENABLED by default; will connect to IMAP port on local server
'disabled' => false,
'name' => 'IMAP Server',
'hostspec' => 'localhost',
'hordeauth' => false,
'protocol' => 'imap',
'port' => 143,
// Plaintext logins are disabled by default on IMAP servers (see RFC 3501
// [6.2.3]), so TLS is the only guaranteed authentication available by
// default.
'secure' => 'tls',
'debug' => '/tmp/imp_imap.log'
);

I don't think, this is disabled...

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Maurício Jsé T. Tecles
2017-02-13 15:40:26 UTC
Permalink
Post by Luca Bertoncello
Post by Luca Bertoncello
What have I to add?
'debug' => '/tmp/imp_imap.log'
in the section "$servers['imap']", but it does not work...
Take a look at http://wiki2.dovecot.org/Logging

Quoting: "Dovecot doesn't leak any extra information about it to clients"

So configure Dovecot to the level of log (and where to log) you want
for the moment, then change back to the normal log.

Mauricio
Post by Luca Bertoncello
Are you sure the 'imap' configuration is the active one? Do you
have a backends.local.php file?
No, I haven't...
$servers['imap'] = array(
// ENABLED by default; will connect to IMAP port on local server
'disabled' => false,
'name' => 'IMAP Server',
'hostspec' => 'localhost',
'hordeauth' => false,
'protocol' => 'imap',
'port' => 143,
// Plaintext logins are disabled by default on IMAP servers (see RFC 3501
// [6.2.3]), so TLS is the only guaranteed authentication available by
// default.
'secure' => 'tls',
'debug' => '/tmp/imp_imap.log'
);
I don't think, this is disabled...
Thanks
Luca Bertoncello
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
--
Maurício José T. Tecles
Instituto de Biofísica Carlos Chagas Filho/UFRJ
Av. Carlos Chagas Filho, 373
Núcleo de Informática
CCS, Bloco G, sala G1-006
Cidade Universitária - Ilha do Fundão
21941-902, Rio de Janeiro - RJ

***@biof.ufrj.br
Tel.: (21) 3938-6526 ou 3938-6544
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.hord
Luca Bertoncello
2017-02-13 15:43:52 UTC
Permalink
Zitat von "Maurício Jsé T. Tecles" <***@biof.ufrj.br>:

Hi Maurício
Post by Maurício Jsé T. Tecles
Take a look at http://wiki2.dovecot.org/Logging
Quoting: "Dovecot doesn't leak any extra information about it to clients"
So configure Dovecot to the level of log (and where to log) you want
for the moment, then change back to the normal log.
Yes, I did it...
But I don't see any useful information:

Feb 13 15:23:10 imap-login: Info: Login: user=<lucabert>,
method=PLAIN, rip=::1, lip=::1, mpid=14455, TLS,
session=<rxHjL2pI8gAAAAAAAAAAAAAAAAAAAAAB>
Feb 13 15:23:10 imap: Debug: Added userdb setting:
mail=maildir:/var/spool/mail/lucabert/Maildir:INDEX=MEMORY:INBOX=/var/spool/mail/lucabert/Maildir
Feb 13 15:23:10 imap(lucabert): Debug: Effective uid=1000, gid=100,
home=/tmp/dc.lucabert
Feb 13 15:23:10 imap(lucabert): Debug: Home dir not found: /tmp/dc.lucabert
Feb 13 15:23:10 imap(lucabert): Debug: Namespace inbox: type=private,
prefix=, sep=, inbox=yes, hidden=no, list=yes, subscriptions=yes
location=maildir:/var/spool/mail/lucabert/Maildir:INDEX=MEMORY:INBOX=/var/spool/mail/lucabert/Maildir
Feb 13 15:23:10 imap(lucabert): Debug: maildir++:
root=/var/spool/mail/lucabert/Maildir, index=, indexpvt=, control=,
inbox=/var/spool/mail/lucabert/Maildir, alt=
Feb 13 15:23:12 imap(lucabert): Info: Disconnected: Logged out in=6724
out=59085

Do you see something useful?

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-uns
Maurício Jsé T. Tecles
2017-02-13 15:51:43 UTC
Permalink
Post by Luca Bertoncello
Hi Maurício
Post by Maurício Jsé T. Tecles
Take a look at http://wiki2.dovecot.org/Logging
Quoting: "Dovecot doesn't leak any extra information about it to clients"
So configure Dovecot to the level of log (and where to log) you
want for the moment, then change back to the normal log.
Yes, I did it...
Feb 13 15:23:10 imap-login: Info: Login: user=<lucabert>,
method=PLAIN, rip=::1, lip=::1, mpid=14455, TLS,
session=<rxHjL2pI8gAAAAAAAAAAAAAAAAAAAAAB>
mail=maildir:/var/spool/mail/lucabert/Maildir:INDEX=MEMORY:INBOX=/var/spool/mail/lucabert/Maildir
Feb 13 15:23:10 imap(lucabert): Debug: Effective uid=1000, gid=100,
home=/tmp/dc.lucabert
Feb 13 15:23:10 imap(lucabert): Debug: Home dir not found: /tmp/dc.lucabert
Is this correct? home=/tmp/dc.lucabert, Debug: Home dir not found:
/tmp/dc.lucabert

Mauricio
Post by Luca Bertoncello
type=private, prefix=, sep=, inbox=yes, hidden=no, list=yes,
subscriptions=yes
location=maildir:/var/spool/mail/lucabert/Maildir:INDEX=MEMORY:INBOX=/var/spool/mail/lucabert/Maildir
root=/var/spool/mail/lucabert/Maildir, index=, indexpvt=, control=,
inbox=/var/spool/mail/lucabert/Maildir, alt=
Feb 13 15:23:12 imap(lucabert): Info: Disconnected: Logged out
in=6724 out=59085
Do you see something useful?
Thanks
Luca Bertoncello
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
--
Maurício José T. Tecles
Instituto de Biofísica Carlos Chagas Filho/UFRJ
Av. Carlos Chagas Filho, 373
Núcleo de Informática
CCS, Bloco G, sala G1-006
Cidade Universitária - Ilha do Fundão
21941-902, Rio de Janeiro - RJ

***@biof.ufrj.br
Tel.: (21) 3938-6526 ou 3938-6544
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mai
Luca Bertoncello
2017-02-13 16:35:03 UTC
Permalink
Post by Luca Bertoncello
Post by Luca Bertoncello
Feb 13 15:23:10 imap-login: Info: Login: user=<lucabert>,
method=PLAIN, rip=::1, lip=::1, mpid=14455, TLS,
session=<rxHjL2pI8gAAAAAAAAAAAAAAAAAAAAAB>
mail=maildir:/var/spool/mail/lucabert/Maildir:INDEX=MEMORY:INBOX=/var/spool/mail/lucabert/Maildir
Feb 13 15:23:10 imap(lucabert): Debug: Effective uid=1000, gid=100,
home=/tmp/dc.lucabert
Feb 13 15:23:10 imap(lucabert): Debug: Home dir not
found: /tmp/dc.lucabert
/tmp/dc.lucabert
Why do I need a "home"? I setted it to somewhat, but surely not for the home
of the user (that not always exists...).

Regards
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubs
Luca Bertoncello
2017-02-13 16:36:45 UTC
Permalink
You, or an admin, has disabled dovecot's mailbox indexes. This is
where MODSEQ values are stored.
Well, I didn't disabled anything... But it can be, that I didn't enabled
them... :)

Could you say me, HOW can I enable the mailbox indexes?

Thanks
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Luca Bertoncello
2017-02-13 15:55:06 UTC
Permalink
This is completely different than what I'm suggesting. I'm asking
for *horde's* IMAP debugging log to see *exactly* what horde is
sending and receiving. This is a separate log than any logging done
by the IMAP server itself. This should work as long as the webserver
has write access to the configured directory.
OK, I got Horde logging...

Here something maybe interesting:

S: * OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID
ENABLE IDLE STARTTLS AUTH=PLAIN AUTH=LOGIN AUTH=DIGEST-MD5
AUTH=CRAM-MD5] Dovecot on lucabert.de ready.
C: 1 STARTTLS
S: 1 OK Begin TLS negotiation now.
Command 1 took 0,0008 seconds.
Successfully completed TLS negotiation.
C: 2 AUTHENTICATE PLAIN [INITIAL CLIENT RESPONSE (username: lucabert)]
S: 2 OK [CAPABILITY IMAP4rev1 LITERAL+ SASL-IR LOGIN-REFERRALS ID
ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS
THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT
CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC
ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS SPECIAL-USE
BINARY MOVE] Logged in
Command 2 took 0,0151 seconds.
CACHE: Using the Horde_Imap_Client_Cache_Backend_Cache storage driver.
C: 3 ENABLE QRESYNC
C: 4 SELECT INBOX
S: * ENABLED QRESYNC
S: 3 OK Enabled.
Command 3 took 0,0028 seconds.
S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft NonJunk $forwarded)
S: * OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft
NonJunk $forwarded \*)] Flags permitted.
S: * 21 EXISTS
S: * 0 RECENT
S: * OK [UNSEEN 20] First unseen.
S: * OK [UIDVALIDITY 1334757505] UIDs valid
S: * OK [UIDNEXT 64448] Predicted next UID
S: * OK [NOMODSEQ] No permanent modsequences
S: 4 OK [READ-WRITE] Select completed (0.001 secs).
Command 4 took 0,0083 seconds.
C: 5 UID STORE 64447 +FLAGS \seen
S: 5 OK Store completed.
Command 5 took 0,0024 seconds.
C: 6 UID MOVE 64447 Trash
S: * OK [COPYUID 1334757512 64447 6918] Moved UIDs.
CACHE: Ignoring moving FETCH data (INBOX => Trash)
S: * VANISHED 64447
CACHE: Deleted messages [INBOX; 64447]
S: 6 OK Move completed.
Command 6 took 0,1185 seconds.
C: 7 UID SORT RETURN (ALL COUNT) (DATE) US-ASCII ALL
S: * ESEARCH (TAG "7") UID ALL
62362,62361,62360,62359,62358,62357,62356,62355,62354,62353,62352,62351,62350,62349,62348,62347,64377,64379:64380,64438 COUNT
20
S: 7 OK Sort completed (0.002 secs).
Command 7 took 0,0053 seconds.
C: 8 LOGOUT
S: * BYE Logging out
S: 8 OK Logout completed.
Command 8 took 0,0018 seconds.
As I delete the message I got the error in Horde.
What does this "No permanent modsequences" means? How can I resolve it?

Thanks a lot!
Luca Bertoncello
(***@lucabert.de)
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-***@lists.horde.org
Maurício Jsé T. Tecles
2017-02-13 16:14:14 UTC
Permalink
Post by Maurício Jsé T. Tecles
Post by Luca Bertoncello
Post by Luca Bertoncello
What have I to add?
'debug' => '/tmp/imp_imap.log'
in the section "$servers['imap']", but it does not work...
Take a look at http://wiki2.dovecot.org/Logging
Quoting: "Dovecot doesn't leak any extra information about it to clients"
So configure Dovecot to the level of log (and where to log) you
want for the moment, then change back to the normal log.
This is completely different than what I'm suggesting. I'm asking
for *horde's* IMAP debugging log to see *exactly* what horde is
sending and receiving. This is a separate log than any logging done
by the IMAP server itself. This should work as long as the webserver
has write access to the configured directory.
You are right! I was just seeing Dovecot's side view. I am sorry!

Mauricio
Post by Maurício Jsé T. Tecles
Mauricio
Post by Luca Bertoncello
Are you sure the 'imap' configuration is the active one? Do you
have a backends.local.php file?
No, I haven't...
$servers['imap'] = array(
// ENABLED by default; will connect to IMAP port on local server
'disabled' => false,
'name' => 'IMAP Server',
'hostspec' => 'localhost',
'hordeauth' => false,
'protocol' => 'imap',
'port' => 143,
// Plaintext logins are disabled by default on IMAP servers (see RFC 3501
// [6.2.3]), so TLS is the only guaranteed authentication available by
// default.
'secure' => 'tls',
'debug' => '/tmp/imp_imap.log'
);
I don't think, this is disabled...
Thanks
Luca Bertoncello
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
--
Maurício José T. Tecles
Instituto de Biofísica Carlos Chagas Filho/UFRJ
Av. Carlos Chagas Filho, 373
Núcleo de Informática
CCS, Bloco G, sala G1-006
Cidade Universitária - Ilha do Fundão
21941-902, Rio de Janeiro - RJ
Tel.: (21) 3938-6526 ou 3938-6544
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
--
mike
The Horde Project
http://www.horde.org
https://www.facebook.com/hordeproject
https://www.twitter.com/hordeproject
--
Maurício José T. Tecles
Instituto de Biofísica Carlos Chagas Filho/UFRJ
Av. Carlos Chagas Filho, 373
Núcleo de Informática
CCS, Bloco G, sala G1-006
Cidade Universitária - Ilha do Fundão
21941-902, Rio de Janeiro - RJ

***@biof.ufrj.br
Tel.: (21) 3938-6526 ou 3938-6544
--
Horde mailing list
Frequently Asked Questions: http://horde.org/faq/
To unsubscribe, mail: horde-u
Continue reading on narkive:
Loading...